Page 46 of 54 FirstFirst ... 364445464748 ... LastLast
Results 451 to 460 of 539
  96 96 Attachment(s)    

Thread: vForce Like EA

  1. #451

    Default

    Quote Originally Posted by bt2 View Post
    I used v1.1 with the StoM<StoS fix put into the sell tests, about halfway down the code.
    Dont know how to get my saved set files out yet (none show in my \experts\presets folder although I have saved plenty).
    My settings are standard except for RPeriod 21, MarginPips 17, StopLoss 75.

    I used to run v202 as it was the only corrected code as errors etc were found. Ran it on M15 EurUsd. Showed up plenty of trades to be able to follow the trading logic & check the ea was handling the trades correctly. Wasnt too bad, but hit a stoploss a bit too often.
    So looked back at the fixed v1.1 cause of the 4xProject writeup spin on "Magic Machine".

    cheers bt2
    thanks. i made that change to the code and have it trading both sides now.

    what a pain they seem to disappear. i usually either save my .set files with the EA file directory.

    if they still dont show up. when you 'save report' up the top will list all the variables and their values.

    cut and past them, or upload your full backtest to the board.

    i have a program which i can analyise backtests and use the detailed mt4 statements to run monte carlo and analyise trade times and other things.

    so if people doing backtests can post up their detailed statements i can run it through the program and offer insights which are perhaps not seen at first glance.

    i tried to recreate your results with defaults + those chances but they didnt seem to have the same results. maybe my 'defaults' are different to yours.

    upload your detailed statement htm file and ill run it through my program and give analysis.

  2. #452
    Junior Member
    Join Date
    May 2009
    Posts
    17

    Default Backtesting Errors

    I've been backtesting VForce v1.1, and I've noticed quite a lot of errors showing up in the Journal. These are some of the errors I am seeing:

    2009.07.17 20:37:54 TestGenerator: unmatched data error (high value 1.3206 at 2009.03.31 02:00 is not reached from the least timeframe, high price 1.3190 mismatches)

    2009.07.17 20:38:12 2008.07.28 07:00 vForce Like EA v1.1 EURUSD,H1: OrderSend error 130

    2009.07.17 20:40:10 2009.03.23 05:00 vForce Like EA v1.1 EURUSD,H1: OrderSend error 4107

    Does anyone have any idea why these are showing up?

    Thanks

  3. #453

    Default Are you using Vista installed computer?

    Quote Originally Posted by bt2 View Post
    I used v1.1 with the StoM<StoS fix put into the sell tests, about halfway down the code.
    Dont know how to get my saved set files out yet (none show in my \experts\presets folder although I have saved plenty).
    My settings are standard except for RPeriod 21, MarginPips 17, StopLoss 75.

    I used to run v202 as it was the only corrected code as errors etc were found. Ran it on M15 EurUsd. Showed up plenty of trades to be able to follow the trading logic & check the ea was handling the trades correctly. Wasnt too bad, but hit a stoploss a bit too often.
    So looked back at the fixed v1.1 cause of the 4xProject writeup spin on "Magic Machine".

    cheers bt2
    If you are using Vista machine, run Windows Exploer:

    Computer\
    OS((C\
    Users\
    Your name (Administrator)\
    AppData\
    Local\
    VirtualStore\
    Program Files\
    Your MT4 Platform\
    experts\
    presets\

    There you might be able to locate your presets if saved properly. Hope this helps!

  4. #454

    Thumbs up Yep using Vista - spot on location

    Quote Originally Posted by Michaelhryu View Post
    If you are using Vista machine, run Windows Exploer:

    Computer\
    OS((C\
    Users\
    Your name (Administrator)\
    AppData\
    Local\
    VirtualStore\
    Program Files\
    Your MT4 Platform\
    experts\
    presets\

    There you might be able to locate your presets if saved properly. Hope this helps!
    Thanks for that Michaelhryu, thats spot on.
    I knew they were in there somewhere, as they all show up from within the platform itself.
    I have actually run into that VirtualStore thing before, but the old memory banks had it as VirtualFolder, so of course I couldnt find it.

    Which reminds me I have been having that "User Account Control - A program needs your permission... " each time I start the platform (doing OK each time makes no difference). Has indicated before that I need to run LiveUpdate.exe for each MT4 platform after switching off the Vista User Account Control for a little while. Should set me up with build 225.

    Best just post the set file 1st. U just never know with these upgrades

    cheers bt2
    Attached Files Attached Files
    Last edited by bt2; 07-19-2009 at 07:48.

  5. #455

    Default What version?

    Quote Originally Posted by bt2 View Post

    Best just post the set file 1st. U just never kow with these upgrades

    What version did you use in your demo testing? vForce Like EA v1.1.mq4 (#3, p. 1), I guess?

    Your results got me interested in this EA again. That is, after two weeks of successful demoing, I ran vForce Like EA v2.mq4 (#15, p. 2) with the vforce like ea v2 no MM eu h1.set (#17) in my FXDD live account. Guess what? first week went beautifully, account grew by 20% or so. Then, 2 big S/L the next week, account shrank to 60% of starting balance. I had to pull off the EA. It all happened about three months ago.

    I'll demo the EA again, anyway. Better luck this time, I hope!

  6. #456
    Junior Member
    Join Date
    Jul 2009
    Posts
    1

    Unhappy Can't get tester to trade

    I'm trying to test the "vForce Like EA v2 EU H1" but for some reason I can't get the tester to actually perform any trades. So there is no loss and no profit. Could anybody tell me what I'm doing wrong?

  7. #457

    Default

    Quote Originally Posted by Michaelhryu View Post
    What version did you use in your demo testing? vForce Like EA v1.1.mq4 (#3, p. 1), I guess?

    Your results got me interested in this EA again. That is, after two weeks of successful demoing, I ran vForce Like EA v2.mq4 (#15, p. 2) with the vforce like ea v2 no MM eu h1.set (#17) in my FXDD live account. Guess what? first week went beautifully, account grew by 20% or so. Then, 2 big S/L the next week, account shrank to 60% of starting balance. I had to pull off the EA. It all happened about three months ago.

    I'll demo the EA again, anyway. Better luck this time, I hope!
    Yep, VForce Like EA v1.1.mq4 #3 pg 1, but with the fix put in.
    Been thinking the trades are taken a little late, thats why I targeted the MarginPips when I optimized a bit.
    I also thought the error 130's maybe caused by trying to post pending orders off the ends of the previous bar. I assume any 130 error is a missed potential trade?
    Unfortunately my last coding attempt at a fix is a bit clumsy. I need the ea to only amend trades that would cause the price conflict (just before).

    There is also an idea I have that some trades are taken too late in the trend, leaving the ea hung out, while the price retraces a bit. Might just be pending orders alive too long, so had reduced my expiration down to even 300 on my M15 v202 demo run.

    cheers bt2

  8. #458

    Default Bug fixes?

    Quote Originally Posted by bt2 View Post
    Yep, VForce Like EA v1.1.mq4 #3 pg 1, but with the fix put in.
    Do you mean you manged to fix the EA thru rewriting codes? Did you otherwise fix the EA's shortcomings thru using your set file? Please clarify on this. If you revised the EA, please post it here. I would appreciate!

  9. #459
    Junior Member
    Join Date
    May 2009
    Posts
    17

    Default Backtesting errors found with VForce v1.1

    I've been backtesting VForce v1.1, and I've noticed quite a lot of errors showing up in the Journal. These are some of the errors I am seeing:

    2009.07.17 20:37:54 TestGenerator: unmatched data error (high value 1.3206 at 2009.03.31 02:00 is not reached from the least timeframe, high price 1.3190 mismatches)

    2009.07.17 20:38:12 2008.07.28 07:00 vForce Like EA v1.1 EURUSD,H1: OrderSend error 130

    2009.07.17 20:40:10 2009.03.23 05:00 vForce Like EA v1.1 EURUSD,H1: OrderSend error 4107

    Does anyone have any idea why these are showing up? Has anyone managed to add code to correct these errors? I believe I've found a good reference site for this, so I thought I would try it out. But if someone has corrected these errors, please let me know.

    I'm trying to find the best available version of VForce Like EA and the correct settings file. When I finally get these, I'll let everyone know of my results.

    Thanks

  10. #460

    Default

    Quote Originally Posted by fxrobot View Post
    I'm trying to find the best available version of VForce Like EA and the correct settings file. When I finally get these, I'll let everyone know of my results.
    I am looking forward to your findings with great expectations!

Similar Threads

  1. vForce Like EA v2
    By funyoo in forum Expert advisors live statements
    Replies: 113
    Last Post: 10-21-2013, 19:59
  2. VForce Like EA v1.1
    By fxrobot in forum Expert advisors live statements
    Replies: 5
    Last Post: 08-29-2009, 15:15
  3. vForce EA Great Trading System
    By iForex in forum Ideas for expert advisors
    Replies: 5
    Last Post: 06-16-2009, 16:00

Tags for this Thread

100, advisor, alpari, alpari uk, analysis, automated trading, automatic, average, backtest, backtesting, bonus, breakeven, broker, brokers, change, closing, coding, color, comparison, copy, correlation, demo, design, divergence, eas, elite, eur, eur/usd, eurjpy, eurusd, expert, expert advisor, experts, forex, free, fxopen, gbpusd, hedging, high, historical, home, how to, indicator, indicators, learn, live, live account, low, magic, magic number, main, managed, manual, manual trading, metatrader, moving average, mq4, mql, mt4, mt5, offer, parabolic sar, power, price action, profit, profitable, programmer, programming, rating, real, research, review, robot, robots, rsi, sales, sells, server, signal, signals, simple, slippage, spread, stoch, stochastic, stop, stoploss, strategy, support, system, test, thank you, time, trader, trading, trading forex, trading system, trading volume, trailing, trend, usd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •