Results 1 to 5 of 5
 4 Attachment(s)    

Thread: The EA is finished , but it runs SLOW when backtesting, WHY?

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    7

    Default The EA is finished , but it runs SLOW when backtesting, WHY?

    Okey , I have this problem , before posting the EA here I would like some help to figure out why besides every setting and code is good , the EA still runs soo slow when backtesting , it takes forever just to back test a week before. Any ideas and help in the EA would be highly appreciated.

    The Indicator goes in the indicator's folder .
    Attached Files Attached Files
    Last edited by knacky; 11-01-2009 at 15:42.

  2. #2
    Junior Member
    Join Date
    Oct 2009
    Posts
    7

    Default

    Still no reply But im not giving up. Here is the most recent backtest on GBPJPY :

    1 month

    The EA is finished , but it runs SLOW when backtesting, WHY?-gbpp-gif
    Knacky's Best.htm

    If I fix it on time , I could publish a long term report.
    P.S: Its a 90% quality report , but it gives me some errors. I dont know why.

    Regards
    Last edited by knacky; 11-04-2009 at 01:15.

  3. #3

    Default

    I ran some backtests and it ran just as fast as any other EA I've written/tested...look at the journal and see if you have errors...
    Are you optimizing or backtesting?? If you're optimizing.... you are optimizing too many parameters...

  4. #4
    Senior Member
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    631

    Default

    works perfectly in all my tests. Don't know what you mean by it gives errors

    Quote Originally Posted by knacky View Post
    Still no reply But im not giving up. Here is the most recent backtest on GBPJPY :

    1 month

    The EA is finished , but it runs SLOW when backtesting, WHY?-gbpp-gif
    Knacky's Best.htm

    If I fix it on time , I could publish a long term report.
    P.S: Its a 90% quality report , but it gives me some errors. I dont know why.

    Regards

  5. #5
    Junior Member
    Join Date
    Feb 2009
    Posts
    25

    Default

    It worked without problem on backtest with me too.

    but the Backtest is slowly ,I think that happen because the Indicator is heavy during the Backtest.

    perhaps the solution u convert the Indicator code to dll file then you will let the EA work with dll file replace the Indicator.
    Last edited by trader12; 11-07-2009 at 06:55.

Similar Threads

  1. code in start() never runs ???
    By Dobby101 in forum MQL programming
    Replies: 1
    Last Post: 03-01-2010, 04:08
  2. MACD Alberto Slow
    By funyoo in forum Expert advisors live statements
    Replies: 0
    Last Post: 09-23-2008, 10:40

Tags for this Thread

backtest, backtesting, gbpjpy, indicator, long term, time

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •